Web user interface service impact
Incident Report for PagerDuty

Summary

From 1:13pm to 1:31pm PDT (4:13pm to 4:31pm EDT) on September 18th, the PagerDuty website was largely unavailable. Event processing and notifications were unaffected.

What Happened?

A deploy caused unforeseen errors in our front-end application. We quickly reverted the change to solve the issue.

What Are We Doing About This?

Our engineers are currently working on improving our rollback procedures and application sanity checks to mitigate recurrences of the issue.

We sincerely apologize for any inconvenience this outage may have caused. If you have any questions, do not hesitate to contact us at support@pagerduty.com.

Posted 7 months ago. Oct 26, 2017 - 20:47 UTC

Resolved
The issue affecting the web UI has been resolved.
Posted 8 months ago. Sep 18, 2017 - 20:40 UTC
Investigating
We are currently experiencing an issue affecting the display of incidents in the web UI. Our engineering team is aware and currently working to resolve it.
Posted 8 months ago. Sep 18, 2017 - 20:29 UTC