Notification Delays
Incident Report for PagerDuty
Resolved
We've recovered and notifications are being delivered normally.
Posted 8 months ago. Mar 15, 2018 - 18:51 UTC
Investigating
We're investigating a delay in notifications. Our engineers are actively monitoring the issue.
Posted 8 months ago. Mar 15, 2018 - 18:38 UTC